Ruby si aggiorna con la versione 1.9.3

Share:
Condividi

Ruby LogoIl team di sviluppo di Ruby ha pubblicato un aggiornamento alle versioni 1.9.2/1.9.3 del linguaggio di programmazione open source per correggere una vulnerabilità trovata nel framework di gestione dei pacchetti RubyGems.

Le versioni di manutenzione del linguaggio di scripting, etichettate rispettivamente 1.9.2-P320 e 1.9.3-p194, includono aggiornamenti a RubyGems per risolvere una vulnerabilità di sicurezza che ha causato il fallimento della verifica del server SSL nei repository remoti.

Questa vulnerabilità è stata risolta vietando reindirizzamenti da connessioni http a https, consentendo la verifica dei certificati SSL in una versione aggiornata di RubyGems 1.8.23.

Per ulteriori informazioni sull’aggiornamento, compreso un elenco completo di correzioni di bug, è possibile consultare l’annuncio di rilascio ufficiale o il file di change log.

Ruby 1.9.2-P320, 1.9.3-p194 sono disponibili per il download dal sito del progetto, entrambi distribuiti con licenza Ruby o GPL.

 

LEGGI ANCHE: Rilasciato Ruby on Rails 3.2

Lascia un Commento

L'indirizzo email non verrà pubblicato. I campi obbligatori sono contrassegnati *


*

È possibile utilizzare questi tag ed attributi XHTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>